Bad ECU? : Suzuki GSX-R Motorcycle Forums: Gixxer.com
» Insurance
» Suzuki GSX-R Prices
» Sponsors
Go Back   Suzuki GSX-R Motorcycle Forums Gixxer.com > Gixxer Forums > GSX-R600 / GSX-R750 General forum > 06-07 GSX-R600/750

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-09-2010, 06:55 PM   #1
Tw3aks
Novice
 
Tw3aks's Avatar
 
Join Date: Mar 2010
Location: 127.0.0.1
Motorcycle: 07 Meanstreak S.E. & 06 GSX-R600
Posts: 41
Bad ECU?

Hey all, I've been rebuilding an GSX-R600 K6 and tried to start it for the first time yesterday and here is what happened...

...Initially it all powered up fine and after the fuel pump charged I went and pressed the start button and what did I hear? A pop and all the electricity went off. So I turned off the bike and checked all the fuses...all were good.

I tried it for a second time and it powered up for 1~ second and then another pop. This time the Signal fuse blew. I talked with some motorcycle repair shops and a guy suggested that it is a bad ECU. I bought it used off Ebay so it's possible but I wanted to know if anyone else has had this problem. And yes, everything in that circuit (Starter motor, starter selonoid, battery, and ground wires) are all connected properly.

Any suggestions are welcome. I'm gonna disconnect everything and put some dilectric grease on all the ends and see if that changes anything.
Tw3aks is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-09-2010, 10:42 PM   #2
MotoMummy
Parts Bitch

 
MotoMummy's Avatar
 
Join Date: May 2005
Location: Austin, TX
Motorcycle: Mummy Bike
Posts: 18,653
Re: Bad ECU?

Give dynojet and Bazzaz a call tomorrow. they both have great customer service and know electronics like crazy. Dynojet has always been a huge help to us with anything electrical related. The guys over there really know their stuff.

Have you checked for a short though or have you installed anything recently? Did you just put in a new wire harness, mods, or anything like that? Have you tried leaving the seat off and looking to see if you see any sparks or anything crazy like that?
MotoMummy is offline   Reply With Quote Quick reply to this message
Old 05-10-2010, 07:40 PM   #3
Tw3aks
Novice
 
Tw3aks's Avatar
 
Join Date: Mar 2010
Location: 127.0.0.1
Motorcycle: 07 Meanstreak S.E. & 06 GSX-R600
Posts: 41
Re: Bad ECU?

I'm rebuilding this bike because I bought it with the entire back end (basically battery backwards) burnt up. So yes I've got a new wiring harness, battery, etc etc. I didn't see any sparks when I tried to start it.

Are those guys free over the phone/email?

Thanks for your quick reply
Tw3aks is offline   Reply With Quote Quick reply to this message
Old 05-13-2010, 07:50 AM   #4
Tw3aks
Novice
 
Tw3aks's Avatar
 
Join Date: Mar 2010
Location: 127.0.0.1
Motorcycle: 07 Meanstreak S.E. & 06 GSX-R600
Posts: 41
Re: Bad ECU?

any other suggestions?
Tw3aks is offline   Reply With Quote Quick reply to this message
Old 05-14-2010, 12:03 AM   #5
Tw3aks
Novice
 
Tw3aks's Avatar
 
Join Date: Mar 2010
Location: 127.0.0.1
Motorcycle: 07 Meanstreak S.E. & 06 GSX-R600
Posts: 41
Re: Bad ECU?

Just to finalize this post, I made sure all my connections were good and the battery was fully charged and it quit so the ECU is fine!
Tw3aks is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 12:52 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2008 2013 Gixxer.com
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum