07 GSXR600 Speedometer Problem : Suzuki GSX-R Motorcycle Forums: Gixxer.com
» Insurance
» Suzuki GSX-R Prices
» Sponsors
Go Back   Suzuki GSX-R Motorcycle Forums Gixxer.com > Gixxer Forums > GSX-R600 / GSX-R750 General forum > 06-07 GSX-R600/750

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-09-2013, 02:32 PM   #1
InfamousGT
Squid
 
Join Date: Dec 2012
Motorcycle: 2007 GSXR 600
Posts: 4
07 GSXR600 Speedometer Problem

Hey guys I'm having a little problem. I bought an 2007 GSXR 600 with the speedometer not working, it lights up, all of the lighted icons work but the rpms needle will not move, and anything digital is blank. So I said ok ill just buy another speedometer. After riding with it for a couple weeks the new one came. I installed it with no trouble but there is no change, this speedometer is doing the same thing. I'm starting to think I have a bigger problem but besides it being electrical, I have no idea what it would be. Any thoughts or ideas on what it is/what I need to do to fix it?
Attached Images
File Type: jpg photo.jpg (46.5 KB, 76 views)
InfamousGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-09-2013, 03:24 PM   #2
rv6john
Club Racer
 
Join Date: Mar 2010
Location: Western North Carolina
Motorcycle: GSXR 750K6, 2007 Kawasaki Z1000, Aprilia SXV550, DR650
Posts: 1,744
Re: 07 GSXR600 Speedometer Problem

I'm assuming the plug in the back of the display is plugged in all the way and is not damaged.

Check the big plug covered by a white/clear rubber cover just forward and left of the display. The display wiring runs through this plug also.

There is a wiring diagram in the back of the service manual. I could be very helpful tracking this down.

www.servicemanualsgsxr.com
rv6john is offline   Reply With Quote
Old 01-09-2013, 05:27 PM   #3
InfamousGT
Squid
 
Join Date: Dec 2012
Motorcycle: 2007 GSXR 600
Posts: 4
Re: 07 GSXR600 Speedometer Problem

I took a look at the diagram and found where the harness was so I took off the fairings. I noticed as disconnected the plug that there was a connection missing. Only one, but I'm not sure if that's enough to cause the problem. Nothings corroded or broken, that's the only thing out of place.
Attached Images
File Type: jpg photo (1).jpg (45.0 KB, 71 views)
InfamousGT is offline   Reply With Quote
Old 01-09-2013, 06:50 PM   #4
rv6john
Club Racer
 
Join Date: Mar 2010
Location: Western North Carolina
Motorcycle: GSXR 750K6, 2007 Kawasaki Z1000, Aprilia SXV550, DR650
Posts: 1,744
Re: 07 GSXR600 Speedometer Problem

Compare the diagram with the wires in the plug by color code and figure out which one is missing? I think the O/G is power in, but not 100% sure.
rv6john is offline   Reply With Quote
Old 01-15-2013, 10:40 AM   #5
MelEvo
Squid
 
Join Date: Aug 2012
Posts: 13
Re: 07 GSXR600 Speedometer Problem

I have the same issue but nothing missing..
MelEvo is offline   Reply With Quote
Old 01-15-2013, 12:34 PM   #6
InfamousGT
Squid
 
Join Date: Dec 2012
Motorcycle: 2007 GSXR 600
Posts: 4
Re: 07 GSXR600 Speedometer Problem

Yeah I'm not sure if that's a big deal or not but I ohmed out every wire in the front harness and got little to no charge so I'm thinking its either that wire harness or maybe the speed sensor killed everything? I'm running out of things to try
InfamousGT is offline   Reply With Quote
Old 01-15-2013, 12:56 PM   #7
xaznperswaesonx
Lifetime Premium
 
xaznperswaesonx's Avatar
 
Join Date: Sep 2010
Location: Sacramento, CA
Motorcycle: K7 GSXR-600
Posts: 957
Edit Never mind

Last edited by xaznperswaesonx; 01-15-2013 at 01:01 PM.
xaznperswaesonx is online now   Reply With Quote
Old 01-15-2013, 01:02 PM   #8
yaksha79
Rookie
 
yaksha79's Avatar
 
Join Date: Jul 2010
Location: conway arkansas
Motorcycle: 09 GSXR 750 Black/Blue, cat delete, set valve and pair valve delete, moto gp shift, flashed ECU, R6 throttle tube, K&N, Ported 06/07 header, Underbike Yoshi r77, 520 conversion -2in front, HID, Billet levers, braided lines.
Posts: 426
Re: 07 GSXR600 Speedometer Problem

Do you know anyone close by that has an 06-07 gsxr 600/750 that would try your display on their bike? I know it would be highly unlikely to have two bad the same way but not impossible.
yaksha79 is offline   Reply With Quote
Old 01-15-2013, 08:46 PM   #9
rv6john
Club Racer
 
Join Date: Mar 2010
Location: Western North Carolina
Motorcycle: GSXR 750K6, 2007 Kawasaki Z1000, Aprilia SXV550, DR650
Posts: 1,744
Re: 07 GSXR600 Speedometer Problem

Quote:
Originally Posted by InfamousGT View Post
Yeah I'm not sure if that's a big deal or not but I ohmed out every wire in the front harness and got little to no charge so I'm thinking its either that wire harness or maybe the speed sensor killed everything? I'm running out of things to try
Ohmed out but no charge? I have no idea what this means.

The speed sensor will not kill anything. I will just read 0.
rv6john is offline   Reply With Quote
Old 01-16-2013, 09:27 AM   #10
MelEvo
Squid
 
Join Date: Aug 2012
Posts: 13
Re: 07 GSXR600 Speedometer Problem

I have a friend with a working one, so will see whats up.
MelEvo is offline   Reply With Quote
Old 01-17-2013, 04:55 PM   #11
InfamousGT
Squid
 
Join Date: Dec 2012
Motorcycle: 2007 GSXR 600
Posts: 4
Re: 07 GSXR600 Speedometer Problem

Quote:
Originally Posted by yaksha79 View Post
Do you know anyone close by that has an 06-07 gsxr 600/750 that would try your display on their bike? I know it would be highly unlikely to have two bad the same way but not impossible.
Not that I know of, I wish I did. Yes that's what I thought the speed sensor wouldn't affect the digital readout. Maybe a new wire harness for that side?
InfamousGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 09:29 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2008 2013 Gixxer.com
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum