Strange electrical/indicator issue? : Suzuki GSX-R Motorcycle Forums: Gixxer.com
» Insurance
» Suzuki GSX-R Prices
» Sponsors
Go Back   Suzuki GSX-R Motorcycle Forums Gixxer.com > Gixxer Forums > SRADs (97-00 600 and 96-99 750)

Reply
 
Thread Tools Display Modes
Old 12-07-2012, 04:53 AM   #1
Armi
Lifetime Premium
 
Armi's Avatar
 
Join Date: Aug 2009
Location: london,uk
Motorcycle: gsxr 750 srad with a few mods thanks to the members on this site.See signature.
Posts: 9,340
Strange electrical/indicator issue?

Changed the steering head bearings, so had to take the fairings off, which meant disconnecting the front indicators.
Anyway put everything together as it should and now the left indicators work as normal but when I put the right indicators on, the front left blinks faintly as well...if I turn the headlights on, this doesn't happen

Any idea's guys...I hate electrics
Armi is online now   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-07-2012, 06:00 AM   #2
Adsuzukiboy34
Lifetime Premium
 
Adsuzukiboy34's Avatar
 
Join Date: Dec 2006
Location: Gold Coast, Australia
Motorcycle: 1996 Gixxer 750 + K4 1000
Posts: 3,965
Re: Strange electrical/indicator issue?

You indicate? ... LOL

Take them apart and assemble again, making sure that everything is in place (electrical connections/spades etc, and that they are tight and do actually connect).

Indicate with the middle finger brother!

Having said that...

Brother Armi (and a few others, you know who you are; the usual suspects), I'm back after a long hiatus for personal reasons.

RIP Dad; it's nearly been a year, every milestone hurts because it is a reminder of how much we love you.

Sorry to digress my Armi mate, but you helped share my pain many months ago.
Maybe I should have PM'd the last bit.

Cheers, Ad
__________________
Quote:
Originally Posted by Buster Hymen View Post
Having an R bike and not hitting up the track is like having a 12" dong and not doing porn..................just doesn't make sense.
A '96 model 750: a dusting of Harris, a cupful of Yoshi camshafts, some Ohlins essence, a slight sprinkle of Marchesini magnesium, some Keihin kindness, a bit of Brembo, a smattering of EBC, the caress of carbon fibre bodywork, a brace of Gilles rearsets, triple snorkle c/f airbox + kit radiator to suit... Maybe more to come...
Adsuzukiboy34 is offline   Reply With Quote
Old 12-07-2012, 01:12 PM   #3
Armi
Lifetime Premium
 
Armi's Avatar
 
Join Date: Aug 2009
Location: london,uk
Motorcycle: gsxr 750 srad with a few mods thanks to the members on this site.See signature.
Posts: 9,340
Re: Strange electrical/indicator issue?

RIP Uncle Adam
Armi is online now   Reply With Quote
Old 12-07-2012, 07:05 PM   #4
ccmhunt
Carb Ninja
 
ccmhunt's Avatar
 
Join Date: Jan 2009
Location: Lawton, Ok
Motorcycle: 96 GSXR750, 07 CBR1KRR, ZX7/9RR F-USA AMA
Posts: 10,463
Re: Strange electrical/indicator issue?

yes indeed....Too much of this today though.
ccmhunt is online now   Reply With Quote
Old 12-07-2012, 08:08 PM   #5
oshweeken
Yaah I know!
 
oshweeken's Avatar
 
Join Date: Jan 2005
Location: Mississauga, ON.
Motorcycle: 1999 GSXR 750, 2002 CRF450R, 1974 CZ250, 1996 Yamaha Wavebalster
Posts: 985
Re: Strange electrical/indicator issue?

Sounds like a bad ground Armi!

Sorry for you loss Ad.
oshweeken is offline   Reply With Quote
Old 12-07-2012, 09:27 PM   #6
TT750
Lifetime Premium
 
Join Date: Nov 2007
Location: halifax ns, canada
Motorcycle: 99 750 (sold), 98 tlr (in progress), 07 f650 dakar (daily driver)
Posts: 5,871
Re: Strange electrical/indicator issue?

How is that yellow plug???
TT750 is offline   Reply With Quote
Old 12-08-2012, 03:46 PM   #7
Armi
Lifetime Premium
 
Armi's Avatar
 
Join Date: Aug 2009
Location: london,uk
Motorcycle: gsxr 750 srad with a few mods thanks to the members on this site.See signature.
Posts: 9,340
Re: Strange electrical/indicator issue?

Quote:
Originally Posted by oshweeken View Post
Sounds like a bad ground Armi!

Sorry for you loss Ad.
It's just got one earth wire though, right?

Quote:
Originally Posted by TT750 View Post
How is that yellow plug???
Hmmm...Cheers TT will check that infamous plug!
Armi is online now   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 12:32 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2008 2013 Gixxer.com
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum