Problems with brights? : Suzuki GSX-R Motorcycle Forums: Gixxer.com
» Insurance
» Suzuki GSX-R Prices
» Sponsors
Go Back   Suzuki GSX-R Motorcycle Forums Gixxer.com > Gixxer Forums > GSX-R600 / GSX-R750 General forum > 06-07 GSX-R600/750

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-11-2012, 10:06 AM   #1
Man-baby
Squid
 
Join Date: Aug 2012
Location: Pineville, LA
Motorcycle: 2007 GSXR 750
Posts: 10
Smile Problems with brights?

I bought my K7 750 a few months ago. As sketchy as it does sound, I just now got around to putting bulbs in the bright sockets. It obviously did not have any when I bought it. I guess I figured out why, because they don't work well. When they are out, I click on the brights switch and nothing at all happens... not even the bright indicator on my dash will show. It did come on a few times after trying several times to get them on. Any ideas why it is doing this? The bulbs won't come on and neither will the indicator light. My only guess is a short or maybe the harness is having some problems. Thanks in advance for your help.
Man-baby is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-11-2012, 10:07 AM   #2
Man-baby
Squid
 
Join Date: Aug 2012
Location: Pineville, LA
Motorcycle: 2007 GSXR 750
Posts: 10
Re: Problems with brights?

Correction: When the bulbs are out, the indicator does show that my brights are on when I click the switch. When the bulbs are in, nothing will happen except the two times they actually came on.
Man-baby is offline   Reply With Quote Quick reply to this message
Old 11-11-2012, 11:42 AM   #3
rv6john
Club Racer
 
Join Date: Mar 2010
Location: Western North Carolina
Motorcycle: GSXR 750K6, 2007 Kawasaki Z1000, Aprilia SXV550, DR650
Posts: 1,744
Re: Problems with brights?

Do you get the same symptoms when you press the passing switch?

If the headlight works OK with the passing switch then your problem is in the hi/lo switch.

If it does the same thing then you have a high resistance in the power side of the high beam circuit. (All the front lights share the same ground so that should be good and the high beam indicator is on a separate ground but is acting the same as the high beam.

My guess is that you have a bad connection in the big plug at the front of the bike. The one with the clear/white rubber cover. According to the service manual wiring diagram, the high beam power wire in is Yellow and out to the headlight and indicator is Blue/Yellow. I would check for a voltage drop across that connection.
rv6john is offline   Reply With Quote Quick reply to this message
Old 11-11-2012, 01:31 PM   #4
Man-baby
Squid
 
Join Date: Aug 2012
Location: Pineville, LA
Motorcycle: 2007 GSXR 750
Posts: 10
Re: Problems with brights?

Yea same thing with passing light. Does absolutely nothing with neither of the two. I will surely check that whenever I get a chance. Thanks for the advice.
Man-baby is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 12:18 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2008 2013 Gixxer.com
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum