my 99 gsxr-750 has charging problems - Suzuki GSX-R Motorcycle Forums Gixxer.com
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-15-2010, 07:25 PM Thread Starter
Squid
 
Join Date: Jun 2010
Posts: 9
my 99 gsxr-750 has charging problems

Basically what happened is that I tried starting my bike and it acted like the battery was dead. I decided to try to jump start it by connecting it to a car (the car was off). it started ok, but when we disconnected the jumper cables my bike died. Figuring the charging system was probably broken since I didn't do anything else that might have caused the battery to drain, I tried letting the battery sit connected to the car battery for a few minutes. it gave me enough charge to get to a bike shop.

they told me I need a new battery, stator and regulator. and wanted to charge me a ridiculous amount, so I got the battery, had them charge it, and was able to ride back to my apartment.

I did a load test and it didn't look like any voltage was going to the battery at 5000 rpm. The shop said the alternator wasn't outputting anything too, so I believe that the stator needs to be replaced. but how can I tell if I need to replace the rectifier too?


tldr; I am pretty sure I need a new stator for my bike. How can I tell if I need a new rectifier? is it true that if the stator goes bad then the rectifier goes bad too?

thanks
cketcham is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-11-2010, 10:46 AM Thread Starter
Squid
 
Join Date: Jun 2010
Posts: 9
Re: my 99 gsxr-750 has charging problems

for anyone who is interested in knowing what I did to get my bike fixed.

I replaced the battery and the reg/rec and it now works fine. I'm not sure if the shop people were totally talking out of their asses when they said I needed to replace everything since I performed a test before I changed anything that made me believe I needed to replace the reg/rec, I performed the same test after I replaced it, got the same result, except the battery charges now.
cketcham is offline  
post #3 of 5 (permalink) Old 11-11-2010, 10:50 AM
!##NULL##!
 
THE SRADIATOR's Avatar
 
Join Date: Nov 2001
Location: Works & Plays Well with Others (Sometimes)
Motorcycle: THE SRADIATOR
Posts: 23,122
Re: my 99 gsxr-750 has charging problems

You're a few rpm's behind the power curve on this one!
We've been diagnosing and fixing this problem for years now.
You may still have some wiring harness issues as a bad regulator sometimes cooks the harness as well.
Time will tell...
THE SRADIATOR is offline  
post #4 of 5 (permalink) Old 11-11-2010, 11:49 AM
Amateur
 
Join Date: Jun 2004
Location: British Columbia, Canada
Motorcycle: gsxr k7 1000
Posts: 1,029
Re: my 99 gsxr-750 has charging problems

stator is charred, what else do i need?

read this thread..
john kinzell is offline  
post #5 of 5 (permalink) Old 11-11-2010, 11:57 AM Thread Starter
Squid
 
Join Date: Jun 2010
Posts: 9
Re: my 99 gsxr-750 has charging problems

actually the wiring harness had been removed previously and the reg/rec was directly soldered to the bike. I took out the old one, soldered in the new one and I haven't had a problem for 6 months. so hopefully things are good.
cketcham is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome