fuel filter into fuel pump?gsxr1000 K7 - Suzuki GSX-R Motorcycle Forums Gixxer.com
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-21-2009, 09:49 PM Thread Starter
G20VTR's Avatar
Join Date: Jul 2008
Posts: 56
Lightbulb fuel filter into fuel pump?gsxr1000 K7

hi dudes,

I have a gsxr 1000 k7 and it has running problems between 9k/11k rpms, a friend of mine tell me its probably the fuel filter of the fuel pump its dirty, so the question is, The fuel pump in this bike have a fuel filter on it? anyone have a diagram of the fuel pump and filter, and how to cleaning? something like this? http://www.r6messagenet.com/forums/r...tch-tanks.html

PD, sorry for my bad english, i speak better in spanish or italian

Last edited by G20VTR; 08-21-2009 at 10:06 PM.
G20VTR is offline  
Sponsored Links
post #2 of 4 (permalink) Old 09-01-2009, 02:36 PM
Join Date: Jul 2009
Motorcycle: 2002 GSXR 600 Telefonica MoviStar
Posts: 51
Re: fuel filter into fuel pump?gsxr1000 K7

Man.... I'm having the same problems with my 02 gsxr 600. Started off just like your sayin'........ sluggish and boggy while 90% - wide open throttle, but it's been getting worse....like 70% - wide open throttle now. I took my pump, injectors, and fuel rail off last week and cleaned them all, but my bike has two fuel filters (high and low speeds or something) and the high speeds not serviceable!!! I'm just looking into a new pump and filters now.....
youngcaesar8 is offline  
post #3 of 4 (permalink) Old 05-22-2011, 10:20 AM
Join Date: May 2011
Posts: 11
Re: fuel filter into fuel pump?gsxr1000 K7

My 06 600 has the sdame problem any results for problem guys??
ande6009 is offline  
post #4 of 4 (permalink) Old 05-31-2011, 08:21 PM
JKGray's Avatar
Join Date: Apr 2011
Location: Oklahoma
Motorcycle: K6 GSXR 600
Posts: 27
Re: fuel filter into fuel pump?gsxr1000 K7

I had the same problem. My bike would surge and jerk and bog down while above 4k rpms. I have a 06 gsxr 600 that i bought about a month ago and the previous owner rode it 200 miles in 2 years. (the bike set in his garage for a long time.) It did the surging when i just bought the bike but it cleared up after i flushed the tank and added fresh gas and changed the plugs. about 3 weeks after the "tune up" I got low on gas and was "hot rodding" and it started doing the surging. my guess is whatever was settled at the bottom of the tank was being sucked up my the filter. I then took my tank off and then took my fuel pump out. I was disgusted by how much dirt, rust and other stuff was caked onto the filter. I got some carb and choke cleaner and sprayed the piss out of the filter screen and scrubbed it clean. I put it all back together and put 93 octane gas with an additive. It now runs like a dream. be careful not to add too much additive though as it will make your bike run hotter and could do more harm than good. i only add some additives every other filling.

Another note: if you ever store your bike for a long period of time, fill it up with gas and add a stabalizer. Do not let it set with an empty tank. this will allow rust to form. unfortunatly this is what happend to mine by previous owner.
JKGray is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome