c42 ignition problems - Suzuki GSX-R Motorcycle Forums Gixxer.com
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 12-09-2012, 07:29 AM Thread Starter
Novice
 
jonchadwick's Avatar
 
Join Date: May 2012
Location: England, UK
Motorcycle: GSX-R 600 K3
Posts: 87
c42 ignition problems

hi.

had problems with starting my bike, (fuel pump not priming) thought it was my datatool immobilisers playing up so stripped that out only to find problem still there. went and got brand new ignition and fuel cap, plugged it in to test and first turn the fuel pump primed and all was good, switched it to off and back on again and nothing!! tried 20+ times and still nothing.

going to test wires past the ignition coupling bit later, to see if its them. any other ideas, suggestions would be appreciated greatly. need her bac on the road for first thing in the morning.

thanks jon
jonchadwick is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 12-10-2012, 01:58 PM Thread Starter
Novice
 
jonchadwick's Avatar
 
Join Date: May 2012
Location: England, UK
Motorcycle: GSX-R 600 K3
Posts: 87
Re: c42 ignition problems

any1 got any ideas?

have checked there is power going to ecm from ignition, all connectors/couplings look good, fuses all are fine, check sidestand switch, cam position sensor had bit of oil type liquid in there which im told is normal.

tempted just to re wire the hole damn thing!!!
jonchadwick is offline  
post #3 of 7 (permalink) Old 12-17-2012, 02:35 AM
Squid
 
babe's Avatar
 
Join Date: Jul 2010
Location: Ojai, CA
Motorcycle: 2001 GSXR 600, 07 Ninja 250
Posts: 26
Did you get the F1 code? I had this. It was my TPS sensor.

Sent from my DROID4 using Motorcycle.com Free App
babe is offline  
post #4 of 7 (permalink) Old 12-22-2012, 10:34 AM Thread Starter
Novice
 
jonchadwick's Avatar
 
Join Date: May 2012
Location: England, UK
Motorcycle: GSX-R 600 K3
Posts: 87
Re: c42 ignition problems

got c42 as fault code which is igntion wiring/couplings.

right then just thought id update how its going...

managed to find out by mistake that touching the gear lever (either up or down) i can get the bike to come out of FI mode and the fuel pump primes, bike starts and rides pretect as normal.

ive think it could be the gear postions sensor or a friend of mine has mentioned the netural switch, havent checked sensors or wiring yet but think im definatly getting close to solving my problem.
jonchadwick is offline  
post #5 of 7 (permalink) Old 12-22-2012, 07:49 PM
Squid
 
avgas24's Avatar
 
Join Date: Aug 2006
Location: queen creek az
Motorcycle: 01 gsxr750, 06 CRF 450
Posts: 17
Re: c42 ignition problems

I would check the contact points for cleanliness when you remove the sensor.
avgas24 is offline  
post #6 of 7 (permalink) Old 12-23-2012, 01:20 PM Thread Starter
Novice
 
jonchadwick's Avatar
 
Join Date: May 2012
Location: England, UK
Motorcycle: GSX-R 600 K3
Posts: 87
Re: c42 ignition problems

Quote:
Originally Posted by avgas24 View Post
I would check the contact points for cleanliness when you remove the sensor.
will be doing so after reading your thread cheers electrical contact cleaner on standby

have you had anymore problems, or has it solved your problem for good?
jonchadwick is offline  
post #7 of 7 (permalink) Old 12-23-2012, 06:55 PM
Squid
 
avgas24's Avatar
 
Join Date: Aug 2006
Location: queen creek az
Motorcycle: 01 gsxr750, 06 CRF 450
Posts: 17
Re: c42 ignition problems

As far as i am concerned, it is fixed. It doesn't rain much here in AZ, but when it does i get soaked. I have put almost 90,000 miles on my bike, I bought it with 20,000, and the only thing to let me down has been stators. This has been a great bike. I hope your fix is something simple too.
avgas24 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome